- This article discusses classic functionality. For information on the modern applicant experience, refer to the Applicant Experience Knowledgebase article.
- This article covers questionnaire management prior to the Terra Dotta Study Abroad 20.0 release of the Admin Console in January 2020. For information on available functionality after this date, refer to the Questionnaire Builder Knowledgebase article.
This tool enables you to construct, edit, and retire questionnaires for applicants depending on the cycle of the application process.
Questionnaires on this page are grouped by program phase and listed alphabetically in those groups. This listed displays which applicant types to which the questionnaire applies (internal or external), whether or not the questionnaire is program or term specific, and whether or not it is active and visible to applicants. Elements can be filtered by name or process element tag (see below) using the keyword fields at the top of the page.
By default, this list will open to display questionnaires for the program type you've chosen as your default in Programs > Program Types. You can choose to view questionnaires for other program types by selecting the corresponding type from the dropdown menu on the top left.
Creating a New Questionnaire
To create a new Questionnaire, click the New Questionnaire button on the Questionnaires page.
From here, you can enter a name for your questionnaire, select the type, and provide instructions.
- Note: Two questionnaires cannot share the same name. An error message will be displayed if you attempt to create a questionnaire with the same name as an existing questionnaire.
You can then what phase in which the questionnaire should appear.
- Note: Questionnaires intended to be used to advising applications need to be set to display during the advising phase at this point. A questionnaire that has already been deployed to a different phase cannot later be changed back to advising.
Next, if you have built out process element tags in Settings > Tags, you assign as many of them as you need to the questionnaire. Process element tags allow for easier searching and organization of your questionnaires. Refer to "Editing Process Element tags" below and Managing Application and Process Element Tags for more information about this functionality.
- Note: By making a questionnaire conditional for the applicants, it will only appear to the applicant if they fulfill certain conditions. If you make it a conditional, a text box appears where you can include the conditional question. This question will be presented to applicants before they submit the questionnaire.
If you choose to Apply Applicant Parameter Filters, you can choose which applicants will see the questionnaire. For example, you could choose to deploy that questionnaire only to applicants who are not a US citizen. You can only filter by one parameter and it must be a single selection, multi-selection, yes/no, data lookup, or data lookup w/search parameter.
Finally, check the boxes next to the individual question items that should be included in this questionnaire. Question Items should be made in Settings > Question Items before making a questionnaire.
Click Add to create the new questionnaire. Remember that you will still need to apply the questionnaire to a process map for it to be deployed to applicants. This can be done in the cascade wizard that appears after creation or by going to Process > App Cycles.
Questionnaires can also be imported from the Terra Dotta Community Library by clicking the "Browse TDCL" button from the questionnaire list.
Editing a Questionnaire
To edit an existing questionnaire, perform the following steps:
- Click the edit pencil icon to the right of the name of the questionnaire that you want to edit. The Questionnaire: Edit page opens with the current details.
- To add a new question, click the name of the folder the question item is housed in. Place a check mark next to the question item and select update.
- To remove a question, click the name of the folder the question item is housed in. Remove the check mark next to the question item and select update.
- To manage the sequence of the questions, use the up and down arrows.
- Click Update to save the changes made. Click Cancel to cancel the action or Reset to make fresh changes.
Editing Process Tag Elements
You can see which process element tags have been applied to an element by clicking the tag icon to the right of the element's name.You can edit which process element tags have been applied by clicking the tag icon in the Actions column of the list.
This opens a page on which you select the desired tags and update the list.
Retiring a Questionnaire
The questionnaires included here form a part of the process map that is unique for an application cycle. A process map includes questionnaires and materials that are applicable to the applications in that cycle. They are collectively known as Process Elements.To retire a questionnaire:
- Click the retire icon to the right of the name of the questionnaire that you want to mark as retired. A dialog box appears asking you to confirm the action.
- Click OK to proceed with the action.
To reinstate a retired questionnaire, perform the following steps.
- Click the reinstate icon to the right of the questionnaire you want to reinstate. A dialog box appears asking you to confirm the action.
- Click OK to proceed with the action.
Troubleshooting Questionnaires
Below are common issues that arise with questionnaires and their solutions:
Symptoms
When a modification is made to the structure or content of a Questionnaire and the change is applied to a current application cycle, applicants who have already saved or submitted the Questionnaire continue to see the prior version, even if the questionnaire response is "unreceived." New or changed questions do not appear.
Cause
Because of the complex structure of Questionnaires, process versioning will not affect applicants who have already saved or submitted responses. This is the case even if an administrator uses the "Unreceive" (two green arrows icon) operation in the applicant admin area.
Any applicant who has not yet submitted a response will see the modified version, if applied appropriately using Process Version Management.
Resolution
An applicant that has saved or submitted an older version of a questionnaire will only get the new version deployed to them if an admin 'resets' the questionnaire in the application by using the eraser icon.
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